
<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head>
<meta charset="UTF-8" />
<title>
            Admittedly, Cold Feet’s Fay Ripley Has Had Some Really Bad Jobs - Vision TV Channel Canada        </title>
<link rel="alternate" type="application/rss+xml" title="Vision TV Channel Canada RSS Feed" href="http://www.visiontv.ca/feed/" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="stylesheet" type="text/css" media="all" href="http://www.visiontv.ca/wp-content/themes/vision/style.css?v=0.1" />
<link href="//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet">
<link rel="stylesheet" type="text/css" media="all" href="http://www.visiontv.ca/wp-content/themes/vision/css/bootstrap.css?v=1.0" />
<link rel="shortcut icon" href="http://www.visiontv.ca/wp-content/themes/vision/favicon.ico" />
<link rel="pingback" href="http://www.visiontv.ca/xmlrpc.php" />
<script type="text/javascript">
            var switchTo5x = true;
        </script>
<script type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">
            stLight.options({
                publisher: '014fb8d4-5b50-49fb-adc5-59618891eb89',
                theme: '2'
            });
        </script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script> (adsbygoogle = window.adsbygoogle || []).push({ google_ad_client: "ca-pub-7801707814008003", enable_page_level_ads: true }); </script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta property="fb:pages" content="253452887351" />
<meta name="google-site-verification" content="i7kcVG86oH80J7DDI2qrUuRVES5X7ts7_1gn5BzyWTg" />

<meta name="description" content="If you ever thought all acting jobs were created equal, you may want to ask Fay Ripley of &quot;Cold Feet&quot; about her experiences." />
<meta name="robots" content="noodp" />
<link rel="canonical" href="http://www.visiontv.ca/2017/11/28/cold-feet-fay-ripley-bad-jobs/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Admittedly, Cold Feet’s Fay Ripley Has Had Some Really Bad Jobs - Vision TV Channel Canada" />
<meta property="og:description" content="If you ever thought all acting jobs were created equal, you may want to ask Fay Ripley of &quot;Cold Feet&quot; about her experiences." />
<meta property="og:url" content="http://www.visiontv.ca/2017/11/28/cold-feet-fay-ripley-bad-jobs/" />
<meta property="og:site_name" content="Vision TV Channel Canada" />
<meta property="article:tag" content="Acting" />
<meta property="article:tag" content="British" />
<meta property="article:tag" content="Cold Feet" />
<meta property="article:tag" content="Fay Ripley" />
<meta property="article:tag" content="Jobs" />
<meta property="article:section" content="Articles" />
<meta property="article:published_time" content="2017-11-28T15:04:02-05:00" />
<meta property="fb:admins" content="625498981" />
<meta property="og:image" content="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2017/10/06114829/COLD_FEET_SR7_EP5_18.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="338" />

<link rel='dns-prefetch' href='//p.jwpcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.visiontv.ca\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='zms.css-css' href='http://www.visiontv.ca/wp-content/plugins/zm-slideshow-vtv/css/default.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='otw_sbm.css-css' href='http://www.visiontv.ca/wp-content/plugins/widget-manager-light/css/otw_sbm.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='http://www.visiontv.ca/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='dcwss-css' href='http://www.visiontv.ca/wp-content/plugins/wordpress-social-stream/css/dcwss.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css' href='http://www.visiontv.ca/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.2' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://www.visiontv.ca/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='slb_core-css' href='http://www.visiontv.ca/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap_css-css' href='http://www.visiontv.ca/wp-content/themes/vision/css/bootstrap.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='main_css-css' href='http://www.visiontv.ca/wp-content/themes/vision/style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='http://www.visiontv.ca/wp-includes/css/dashicons.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css' href='http://www.visiontv.ca/wp-includes/js/thickbox/thickbox.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='anythingslider-base-css' href='http://www.visiontv.ca/wp-content/plugins/anythingslider-for-wordpress/css/anythingslider.css?ver=4.7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.visiontv.ca/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-content/plugins/zm-slideshow-vtv/js/jquery.cycle.all.min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-content/plugins/anythingslider-for-wordpress/js/jquery.anythingslider.min.js?ver=1.7.26'></script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-content/plugins/wordpress-social-stream/js/jquery.social.stream.wall.1.6.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-content/plugins/wordpress-social-stream/js/jquery.social.stream.1.5.13.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://p.jwpcdn.com/6/12/jwplayer.js?ver=4.7.2'></script>
<script type="text/javascript">
        var ajaxurl = 'http://www.visiontv.ca/wp-admin/admin-ajax.php';
        </script>
<link rel='https://api.w.org/' href='http://www.visiontv.ca/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.visiontv.ca/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://www.visiontv.ca/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.visiontv.ca%2F2017%2F11%2F28%2Fcold-feet-fay-ripley-bad-jobs%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.visiontv.ca/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.visiontv.ca%2F2017%2F11%2F28%2Fcold-feet-fay-ripley-bad-jobs%2F&#038;format=xml" />
<script language="JavaScript" type="text/javascript"><!-- 
function expand(param) { 
param.style.display=(param.style.display=="none") ? "" : "none"; 
} 
//--></script>
<script type="text/javascript">
            function showGallerySatellite(id) {
                var data = {
                        action: 'gallery_display',
                        slideshow: id,
                        postID: 141423                };
                jQuery.post(ajaxurl, data, function(response) {
                        jQuery('.satl-gal-titles .current').removeClass('current');
                        jQuery('.gal'+id).addClass('current');
                        jQuery('.galleries-satl-wrap').html(response);
//                        initslideshow();
                });        
            }
            function showSoloSatellite(id,unique) {
                var data = {
                        action: 'gallery_display',
                        slideshow: id
                };
                jQuery.post(ajaxurl, data, function(response) {
                        jQuery('#splash-satl-wrap-'+unique).html(response);
                });        
            }
        </script>

<style type="text/css">
.stream li.dcsns-twitter .section-intro,.filter .f-twitter a:hover, .wall-outer .dcsns-toolbar .filter .f-twitter a.iso-active{background-color:#4ec2dc!important;}.stream li.dcsns-facebook .section-intro,.filter .f-facebook a:hover, .wall-outer .dcsns-toolbar .filter .f-facebook a.iso-active{background-color:#3b5998!important;}.stream li.dcsns-google .section-intro,.filter .f-google a:hover, .wall-outer .dcsns-toolbar .filter .f-google a.iso-active{background-color:#2d2d2d!important;}.stream li.dcsns-rss .section-intro,.filter .f-rss a:hover, .wall-outer .dcsns-toolbar .filter .f-rss a.iso-active{background-color:#FF9800!important;}.stream li.dcsns-flickr .section-intro,.filter .f-flickr a:hover, .wall-outer .dcsns-toolbar .filter .f-flickr a.iso-active{background-color:#f90784!important;}.stream li.dcsns-delicious .section-intro,.filter .f-delicious a:hover, .wall-outer .dcsns-toolbar .filter .f-delicious a.iso-active{background-color:#3271CB!important;}.stream li.dcsns-youtube .section-intro,.filter .f-youtube a:hover, .wall-outer .dcsns-toolbar .filter .f-youtube a.iso-active{background-color:#DF1F1C!important;}.stream li.dcsns-pinterest .section-intro,.filter .f-pinterest a:hover, .wall-outer .dcsns-toolbar .filter .f-pinterest a.iso-active{background-color:#CB2528!important;}.stream li.dcsns-lastfm .section-intro,.filter .f-lastfm a:hover, .wall-outer .dcsns-toolbar .filter .f-lastfm a.iso-active{background-color:#C90E12!important;}.stream li.dcsns-dribbble .section-intro,.filter .f-dribbble a:hover, .wall-outer .dcsns-toolbar .filter .f-dribbble a.iso-active{background-color:#F175A8!important;}.stream li.dcsns-vimeo .section-intro,.filter .f-vimeo a:hover, .wall-outer .dcsns-toolbar .filter .f-vimeo a.iso-active{background-color:#4EBAFF!important;}.stream li.dcsns-stumbleupon .section-intro,.filter .f-stumbleupon a:hover, .wall-outer .dcsns-toolbar .filter .f-stumbleupon a.iso-active{background-color:#EB4924!important;}.stream li.dcsns-deviantart .section-intro,.filter .f-deviantart a:hover, .wall-outer .dcsns-toolbar .filter .f-deviantart a.iso-active{background-color:#607365!important;}.stream li.dcsns-tumblr .section-intro,.filter .f-tumblr a:hover, .wall-outer .dcsns-toolbar .filter .f-tumblr a.iso-active{background-color:#385774!important;}.stream li.dcsns-instagram .section-intro,.filter .f-instagram a:hover, .wall-outer .dcsns-toolbar .filter .f-instagram a.iso-active{background-color:#413A33!important;}.wall-outer .dcsns-toolbar .filter li a {background:#777;}</style>
<script type="text/javascript">jwplayer.key='Fr4nL42DJEzI7XyObYZLTLTyMfBGUriLLRSIrw==';jwplayer.defaults = { "ph": 2 };</script>
<script type="text/javascript">
            if (typeof(jwp6AddLoadEvent) == 'undefined') {
                function jwp6AddLoadEvent(func) {
                    var oldonload = window.onload;
                    if (typeof window.onload != 'function') {
                        window.onload = func;
                    } else {
                        window.onload = function() {
                            if (oldonload) {
                                oldonload();
                            }
                            func();
                        }
                    }
                }
            }
            </script>

<link rel="amphtml" href="http://www.visiontv.ca/2017/11/28/cold-feet-fay-ripley-bad-jobs/amp/" />
<script type="text/javascript">
                jQuery(document).ready(function () {
                    jQuery('#prisonwives').hide();

                    function fp_GC2(fpc) {
                        var i, x, y, fpcookies = document.cookie.split(";");
                        for (i = 0; i < fpcookies.length; i++) {
                            x = fpcookies[i].substr(0, fpcookies[i].indexOf("="));
                            y = fpcookies[i].substr(fpcookies[i].indexOf("=") + 1);
                            x = x.replace(/^\s+|\s+$/g, "");
                            if (x == fpc) {
                                return unescape(y);
                            }
                        }
                    }

                    function fp_SC2(fpn, fpv, fpExpDays) {
                        var expirydate = new Date();
                        expirydate.setDate(expirydate.getDate() + fpExpDays);
                        var fpvalue = escape(fpv) + ";expires=" + expirydate.toUTCString() + ";path=/";
                        document.cookie = fpn + "=" + fpvalue;
                    }

                    var fppw = fp_GC2("vtv_prison");

                    if (fppw == null || fppw == "" || fppw == "1" || fppw == "2") {
                        if (fppw == null || fppw == "") fpsetcpw = 1;
                        else if (fppw == "1") fpsetcpw = 2;
                        else fpsetcpw = 3;

                        fp_SC2("vtv_prison", fpsetcpw, 180);
                        // shows the prisoners wives as soon as the DOM is ready
                        jQuery('#prisonwives').show();

                    }

                    // hides the prisonerswives  on click
                    jQuery('a#close-prisonwives').click(function () {
                        jQuery('#prisonwives').hide();
                        return false;
                    });
                });
            </script>
<script type="text/javascript">
                jQuery(document).ready(function () {
                    jQuery('.thickbox img').bind("contextmenu", function (e) {
                        return false;
                    });
                });

                jQuery(function () {
                    jQuery('#sb-wrapper').bind('contextmenu', function () {
                        return false;
                    });
                });
            </script>
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
    '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
  googletag.defineSlot('/70671651/VisionTV_Home_Top_728x90', [728, 90], 'div-gpt-ad-1443472345155-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
  });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
  googletag.defineSlot('/70671651/VisionTV_Home_Top_300x250', [300, 250], 'div-gpt-ad-1443472396413-0').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
  });
</script> <link rel='stylesheet' id='channelWidgetStyle-css' href='http://www.visiontv.ca/wp-content/plugins/zm-channel-widget/css/style.css?v=713e2f0fca14c98c96630ea33ee23c9c&#038;ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='newsletterStyle-css' href='http://www.visiontv.ca/wp-content/plugins/zm-newsletter/css/style.css?ver=4.7.2' type='text/css' media='all' />
</head>

<div id='fixed_icons'> <a href="http://www.visiontv.ca/sign-up-for-our-e-newsletter" title="Sign Up for the Visionary Newsletter" onclick="_gaq.push(['_trackEvent', 'ZUMFIXICON-enews','clicked'])"><img src="http://www.visiontv.ca/wp-content/themes/vision/images/icons/icon_newsletter.png" height="36" width="36" alt="E-News Icon" /></a>
<a href="http://www.visiontv.ca/shows/znews/" title="zNews" onclick="_gaq.push(['_trackEvent', 'ZUMFIXICON-znews','clicked'])"><img src="http://www.visiontv.ca/wp-content/themes/vision/images/icons/icon-zNews.png" height="36" width="36" alt="zNews Icon" /></a>

<a href="http://twitter.com/visiontv" title="Follow Vision on Twitter" onclick="_gaq.push(['_trackEvent', 'ZUMFIXICON-twit','clicked'])"><img src="http://www.visiontv.ca/wp-content/themes/vision/images/icons/icon_twitter.png" height="36" width="36" alt="Twitter icon" /></a>
<a href="/feed" title="RSS Feeds" onclick="_gaq.push(['_trackEvent', 'ZUMFIXICON-rss','clicked'])"><img src="http://www.visiontv.ca/wp-content/themes/vision/images/icons/icon_rss.png" height="36" width="36" alt="RSS Feeds" /></a></div></div>
<body class="grad-body">
<section class="main-head">
<div class="container">
<div class="row">
<div class="col-md-10 col-md-offset-1 col-sm-12">
<div class="row">
<div class="col-lg-3">



<a href="http://www.visiontv.ca/" title="Vision TV Channel Canada" rel="home">
<img class="logo" alt="Vision Logo Image" src="http://www.visiontv.ca/wp-content/themes/vision/images/ZoomerTV_Logo_RGB_200x100_Transparent-01.png"></a>


</div>
<div class="col-lg-9 padding-below desktop">

<div id='div-gpt-ad-1443472345155-0' style='height:90px; width:728px;'>
<script type='text/javascript'>
 googletag.cmd.push(function() { googletag.display('div-gpt-ad-1443472345155-0'); });
 </script>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="navigation grad-nav">
<div class="container">

<div class="row">
<nav class="navbar navbar-default">
<div class="container-fluid">

<div class="navbar-header">
<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbarCollapse" aria-expanded="false" aria-controls="navbar">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>

<div id="navbarCollapse" class="collapse navbar-collapse" style="padding: 0;">



<ul id="menu-primary-navigation-1" class="nav navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15"><a title="Home" href="/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-471 dropdown"><a title="Shows" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Shows <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136389"><a title="All Shows" href="http://www.visiontv.ca/category/shows/">All Shows</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-865"><a title="British" href="http://www.visiontv.ca/category/shows/british/">British</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-867"><a title="Canadian Made" href="http://www.visiontv.ca/category/shows/canadian-made/">Canadian Made</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-871"><a title="Comedy" href="http://www.visiontv.ca/category/shows/comedies/">Comedy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-873"><a title="Current Affairs and Lifestyle" href="http://www.visiontv.ca/category/shows/current-affairs-lifestyle/">Current Affairs and Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1319"><a title="Documentaries" href="http://www.visiontv.ca/category/shows/documentaries/">Documentaries</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-879"><a title="Drama" href="http://www.visiontv.ca/category/shows/drama/">Drama</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-881"><a title="Family" href="http://www.visiontv.ca/category/shows/family/">Family</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-887"><a title="Faith and Religion" href="http://www.visiontv.ca/category/shows/faith-and-religion/">Faith and Religion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141247"><a title="Holiday Specials" href="http://www.visiontv.ca/category/shows/holiday-specials/">Holiday Specials</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-mini-series-show menu-item-140348"><a title="Human Rights Series" href="http://www.visiontv.ca/mini-series-show/jew-bashing/">Human Rights Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-889"><a title="Movies" href="http://www.visiontv.ca/category/shows/movies/">Movies</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-891"><a title="Music" href="http://www.visiontv.ca/category/shows/music/">Music</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23"><a title="Schedule" href="http://www.visiontv.ca/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-25"><a title="Articles" href="http://www.visiontv.ca/category/news/">Articles</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61"><a title="Contests" href="http://www.visiontv.ca/category/contests/">Contests</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1633 dropdown"><a title="Get VisionTV" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Get VisionTV <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136388"><a title="Subscribe" href="http://www.visiontv.ca/get-visiontv/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136176"><a title="Channel Finder" href="http://www.visiontv.ca/channel-finder/">Channel Finder</a></li>
</ul>
</li>
</ul>
</div>

</div>

</nav>
</div>

</div>
</section>

<div id="wrapperMain">
<style>

    .alignleft {
        float: left;
        /*width: 100%;*/
    }
    .alignright {
        float: right;
        /*width: 100%;*/
    }
    p{
        margin-bottom: 2rem;
    }

    @media (max-width: 767px) {
        .theEntry img {
            width: 100%;
            float: left;
            height: auto;
        }
    }

</style>
<section class="main">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row shadow-sides">
<div class="col-md-8 front">
<div id="post-141423" class="post-141423 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-acting tag-british tag-cold-feet tag-fay-ripley tag-jobs">
<h1 class="entry-title">Admittedly, Cold Feet’s Fay Ripley Has Had Some Really Bad Jobs</h1>
<div class="entry-meta">
<span class="meta-prep meta-prep-author">Posted on</span> <a href="http://www.visiontv.ca/2017/11/28/cold-feet-fay-ripley-bad-jobs/" title="3:04 pm" rel="bookmark"><span class="entry-date">November 28, 2017</span></a> </div>
<div class="entry-content">
<p style="text-align: center;"><img class="aligncenter size-full wp-image-140431" src="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2017/10/06114829/COLD_FEET_SR7_EP5_18.jpg" alt="Cold Feet - S7" width="600" height="338" srcset="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2017/10/06114829/COLD_FEET_SR7_EP5_18.jpg 600w, http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2017/10/06114829/COLD_FEET_SR7_EP5_18-128x72.jpg 128w, http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2017/10/06114829/COLD_FEET_SR7_EP5_18-300x169.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" /></p>
<p>When we see an actor or actress starring in a series we love, we don’t always think about the path that led to such a point. Sure, we may do a little research to find out what this individual previously starred in, but chances are we won’t be privy to the early, embarrassing jobs that – surprisingly – got the ball rolling.</p>
<p>On “<a href="http://www.visiontv.ca/shows/cold-feet/" target="_blank">Cold Feet</a>,” we know <a href="http://www.visiontv.ca/2017/02/07/cold-feet-fay-ripley-series-flop/" target="_blank">Fay Ripley</a> as Jenny, an outspoken, yet compassionate and comedic woman navigating through family life, social struggles and career changes. But, before Ripley found fame on “Cold Feet” following its 1997 debut, her acting resume was pretty slim.</p>
<p>During an interview with the Mirror, Ripley reflected on the first ever acting job she took. As you might imagine, it was definitely not a glamorous experience.</p>
<p style="text-align: center;"><img class="aligncenter size-full wp-image-133652" src="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2016/12/15121135/Cold_Feet_S6E5_600_7.jpg" alt="Cold Feet" width="600" height="338" srcset="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2016/12/15121135/Cold_Feet_S6E5_600_7.jpg 600w, http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2016/12/15121135/Cold_Feet_S6E5_600_7-128x72.jpg 128w, http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2016/12/15121135/Cold_Feet_S6E5_600_7-300x169.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" /></p>
<p>“I was Miss Chief The Clown, a children’s party entertainer. I had some slightly dramatic things happen,” remembered Ripley. “I was stopped and searched at the airport dressed as her as they looked for drugs stuffed in Sooty’s head. They even took the stuffing out of Harry the Hedgehog in case he was a drugs mule. I cried.</p>
<p>“I was also under suspicion of a massive burglary, set up for an insurance job – the police thought the clown did it,” she continued. “Jewellery went missing and they turned up to search my house, but they’d buried the stuff in the garden.”</p>
<p>As rattling of an experience as <em>that</em> must have been, it was by no means the worst job to be held by Ripley.</p>
<p>“I’ve had loads of bad jobs,” noted the actress. “I’ve sold shirts door-to-door, sold time shares in the high street. I used to lie and tell people we were making an advert – as long as I got them up the stairs I’d get a tenner for it.”</p>
<p><em>-Adam Grant</em></p>
<p style="text-align: center;"><img class="aligncenter size-full wp-image-133631" src="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2016/12/15121102/Cold_Feet_S6E3_600_8.jpg" alt="Cold Feet" width="600" height="338" srcset="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2016/12/15121102/Cold_Feet_S6E3_600_8.jpg 600w, http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2016/12/15121102/Cold_Feet_S6E3_600_8-128x72.jpg 128w, http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2016/12/15121102/Cold_Feet_S6E3_600_8-300x169.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" /></p>
<p style="text-align: center;"><strong><em>This week on “<a href="http://www.visiontv.ca/shows/cold-feet/" target="_blank">Cold Feet</a>” (Wednesday, November 29 at 10pm ET/7pm PT), </em></strong><strong><em>Adam seizes the opportunity to spend the night away from Tina in the name of teambuilding – but finishes up getting more than he bargained for.</em></strong></p>
</div>
<div class="entry-utility">
<div class="unosharethis row">Share:
<span class="st_facebook_large" displayText="Facebook"></span>
<span class="st_twitter_large" displayText="Tweet"></span>
<span class="st_googleplus_large" displayText="Google +"></span>
<span class="st_email_large" displayText="Email"></span>
<span class="st_pinterest_large" displayText="Pinterest"></span>
<span class="st_sharethis_large" displayText="ShareThis"></span>
<span class="st_fblike_large" displayText="Facebook Like"></span>
</div> This entry was posted in <a href="http://www.visiontv.ca/category/news/" rel="category tag">Articles</a> and tagged <a href="http://www.visiontv.ca/tag/acting/" rel="tag">Acting</a>, <a href="http://www.visiontv.ca/tag/british/" rel="tag">British</a>, <a href="http://www.visiontv.ca/tag/cold-feet/" rel="tag">Cold Feet</a>, <a href="http://www.visiontv.ca/tag/fay-ripley/" rel="tag">Fay Ripley</a>, <a href="http://www.visiontv.ca/tag/jobs/" rel="tag">Jobs</a>. Bookmark the <a href="http://www.visiontv.ca/2017/11/28/cold-feet-fay-ripley-bad-jobs/" title="Permalink to Admittedly, Cold Feet’s Fay Ripley Has Had Some Really Bad Jobs" rel="bookmark">permalink</a>. </div>
</div>
<div id="nav-below" class="navigation">
<div class="nav-previous"><a href="http://www.visiontv.ca/2017/11/28/4-weeks-christmas-majestic-music/" rel="prev"><span class="meta-nav">&larr;</span> 4 Weeks of Christmas: Majestic Music Specials for the Holiday Season</a></div>
<div class="nav-next"></div>
</div>
<div id="disqus_thread">
</div>
</div>
<div class="col-md-4">
<div id="sidebar">
<div class="side-line"></div>
<div class="row search widget-area" id="primary" role="complementary">
<div class="col-sm-12">
<form role="search" method="get" id="searchform" class="searchform" action="http://www.visiontv.ca/" data-tf-inspect="-1031051054">
<div class="input-group">
<div id="searchInput">
<input type="text" name="s" id="s" class="form-control" placeholder="Search for...">
</div>
<span class="input-group-btn" id="searchButton">
<button type="submit" class="btn btn-default" id="searchsubmit" type="button">Go!</button>
</span>
</div>
</form>
</div>

</div>

<h3 class="widget-title">Newsletter</h3><script type="text/javascript">function zoomersubscribe(){var $zj = jQuery.noConflict();$zj("#zoomer-sub-widget-form").css("display","none");$zj("#zoomer-sub-widget-loading").css("display","block");$zj("#zoomer-sub-widget").submit();}</script><div id="zoomer-sub-widget-form" name="zoomer-sub-widget-form"><form id="zoomer-sub-widget" method="POST" action="/newsletter-sign-up"><input type="hidden" id="zoomer-sub-widget-subscription" name="zoomer-sub-widget-subscription" value="VisionTV" /><input type="hidden" id="zoomer-sub-widget-redirect" class="form-control" name="zoomer-sub-widget-redirect" value="/newsletter-sign-up" /><div class="input-group"><input type="text" id="zoomer-sub-widget-email" class="form-control" name="zoomer-sub-widget-email" /><span class="input-group-btn"><button class="btn btn-subscribe" id="zoomer-sub-widget-submit" name="zoomer-sub-widget-submit" onclick="javascript: zoomersubscribe(); return false;">Subscribe Now</button></span></div></div><div id="zoomer-sub-widget-loading" name="zoomer-sub-widget-loading" style="display: none;">Loading...</div><h3 class="widget-title">What&#39;s On</h3>
<div id="schedulesidebar">
<table class="table">
<thead>
<tr>
<td>Schedule</td>
<td id="scheduleboxdate">November 28</td>
</thead>
<tbody><script type="text/javascript">
		</script><tr>
<td class="scheduleboxtime">15:30</td>
<td class="scheduleboxprog">Are You Being Served?</td>
</tr><tr>
<td class="scheduleboxtime">16:00</td>
<td class="scheduleboxprog">Little House On The Prairie</td>
</tr><tr>
<td class="scheduleboxtime">16:30</td>
<td class="scheduleboxprog">cont...</td>
</tr><tr>
<td class="scheduleboxtime">17:00</td>
<td class="scheduleboxprog">The Waltons</td>
</tr><tr>
<td class="scheduleboxtime">17:30</td>
<td class="scheduleboxprog">cont...</td>
</tr></tbody></table><div class="scheduleboxnote">Times are listed in ET. See <a href="/schedule/">Full Schedule</a> for additional timezones and information.</div><div class="channelwidget"></div><a href="/channel-finder/"><u>Help with channel finder</u></a><br /><br /><div id="BigBoxAd1">
<div id='div-gpt-ad-1443472396413-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
 googletag.cmd.push(function() { googletag.display('div-gpt-ad-1443472396413-0'); });
 </script>
</div></div><h3 class="widget-title">November/December Notables</h3> <div class="textwidget"><a href="http://www.visiontv.ca/category/shows/holiday-specials/" target=_blank><img src="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2017/11/21125746/4WeeksChristmas_2017_GeneralBanner_600.jpg" alt="4 Weeks of Christmas 2017" title="4 Weeks of Christmas 2017" width="300" height="157" class="aligncenter size-medium wp-image-633" /></a><a href="http://www.visiontv.ca/hitparade" target=_blank><img src="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2017/10/25143058/HitParade_Facebook_DATED_1200x628.jpg" alt="Your All-Time Classic Hit Parade" title="Your All-Time Classic Hit Parade" width="300" height="157" class="aligncenter size-medium wp-image-633" /></a><a href="http://www.visiontv.ca/doc-martin" target=_blank><img src="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2017/10/04121858/Doc_Martin_S8_PREMIERE1_TITLED_600.jpg" alt="Doc Martin Season 8" title="Doc Martin Season 8" width="300" height="169" class="aligncenter size-medium wp-image-633" /></a><a href="http://www.visiontv.ca/cold-feet" target=_blank><img src="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2017/10/04132531/ColdFeet_S7_Cast_PREMIERETITLE_600.jpg" alt="Cold Feet Season 7" title="Cold Feet Season 7" width="300" height="169" class="aligncenter size-medium wp-image-633" /></a><a href="http://www.visiontv.ca/shows/zoomer-yoga-healing-yoga/" target=_blank><img src="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2016/11/16191537/ZoomerHealingYoga_VTV_SidebarWidget_600.jpg" alt="Zoomer Yoga - Healing Yoga" title="Zoomer Yoga - Healing Yoga" width="300" height="169" class="aligncenter size-medium wp-image-633" /></a></div>
<h3 class="widget-title">Watch The Latest ZNews</h3> <div class="textwidget"><a href="https://www.youtube.com/playlist?list=PLHiEom5pFWUIuUcZr4XaZ9W3kijR9e5d8" target=_blank><img src="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2012/03/ZNews_DarrinMaharaj_600x338.jpg" alt="ZNews" title="ZNews" width="300" height="169" class="aligncenter size-medium wp-image-633" /></a></div>
<div id="unofacebookbox"><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, "script", "facebook-jssdk"));</script><div class="fb-like-box" data-href="https://www.facebook.com/visiontelevision" data-width="300" data-show-faces="true" data-stream="false" data-header="true"></div></div><h3 class="widget-title">Call For Program Proposals</h3> <div class="textwidget"><a href="http://www.visiontv.ca/about-vision/producer-guidelines/" target=_blank><img src="http://s3.amazonaws.com/zweb-s3.uploads/visiontv/2016/01/ProducersCalltoAction_2016_Image1_Titled_3001.jpg" alt="2016 Call for Program Proposals" title="2016 Call for Program Proposals" /></a>
<br>
<strong>Experienced Canadian Producers: VisionTV is currently accepting programming proposals for our next broadcast season.</strong> We’re looking for compelling and enlightening programs that celebrate and inform Canada’s Zoomers, our growing 45+ population. Themes such as; global aging trends, health, wellness, lifestyle, and new discoveries related to longevity. Visit our <strong><a href="http://www.visiontv.ca/about-vision/producer-guidelines/" target=_blank>Producers’ Area</a></strong> for full info on how/what to submit.
</br>
</div>
</div>

</div>

</div>

</div>
</div>
</div>
</div>
</section>
</div>
</div>
</div>
</div>
</section>
<footer>
<div class="container">
<div class="row">
<div class="col-sm-10 col-sm-offset-1">
<div class="row">
<div class="col-sm-4">
<h3>About Vision</h3>
<p>VisionTV is Canada’s only English language cable and satellite specialty channel that airs multi-faith, multicultural and family-oriented entertainment. Learn more about Vision.</p>
</div>
<div class="col-sm-4">
<h3>Advertise with Vision</h3>
<p>We welcome the interests of advertisers who want to reach over 10 million homes — and more than 70 diverse communities.</p>
<a href="/about-vision/advertise-with-vision/">Talk with us about advertising with Vision</a>
</div>
<div class="col-sm-4">
<h3>Buy Air Time on Vision</h3>
<p>When you buy air time on VisionTV, we are committed to helping you grow your faith community. Continue on to learn more.</p>
<a href="/about-vision/buying-air-time/">Talk with us about buying air time.</a>
</div>
</div>
</div>
</div>
</div>
</footer>
<section class="footer-links">
<div class="container midcontainer">
<div class="row">
<div class="col-sm-10 col-sm-offset-1">
<div class="row">
<div class="col-sm-12">
<div class="foot-links">
<a href="/about-vision/producer-guidelines/">Producer Area</a>
<a href="/about-vision/legal/">Legal Statement</a>
<a href="/about-vision/code-on-violence/">Code on Violence</a>
<a href="/sign-up-for-our-e-newsletter/">Newsletter</a>
<a href="/about-vision/privacy-policy/">Privacy Policy</a>
<a href="/about-vision/code-on-ethics/">Code on Ethics</a>
<a href="/about-vision/careers/">Careers</a>
<a href="/about-vision/contact/">Contact Us</a>
</div>
</div>
</div>
</div>
</div>
</div>
</section>


<noscript>
        <iframe src="//www.googletagmanager.com/ns.html?id=GTM-5RD8FD" height="0" width="0" style="display:none;visibility:hidden"></iframe>
    </noscript>
<script>
        (function (w, d, s, l, i) {
            w[l] = w[l] || [];
            w[l].push({
                'gtm.start':

                    new Date().getTime(),
                event: 'gtm.js'
            });
            var f = d.getElementsByTagName(s)[0],

                j = d.createElement(s),
                dl = l != 'dataLayer' ? '&l=' + l : '';
            j.async = true;
            j.src =

                '//www.googletagmanager.com/gtm.js?id=' + i + dl;
            f.parentNode.insertBefore(j, f);

        })(window, document, 'script', 'dataLayer', 'GTM-5RD8FD');
    </script>

<script type='text/javascript' src='http://www.visiontv.ca/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/www.visiontv.ca\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.2'></script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-content/themes/vision/js/bootstrap.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.visiontv.ca\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.2","language":""},"disqusIdentifier":"141423 http:\/\/www.visiontv.ca\/?p=141423","disqusShortname":"visiontelevision","disqusTitle":"Admittedly, Cold Feet\u2019s Fay Ripley Has Had Some Really Bad Jobs","disqusUrl":"http:\/\/www.visiontv.ca\/2017\/11\/28\/cold-feet-fay-ripley-bad-jobs\/","options":{"manualSync":false},"postId":"141423"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"visiontelevision"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.visiontv.ca/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.7.2'></script>
<script src="http://www.visiontv.ca/wp-content/plugins/zm-newsletter/zm-newsletter.js "></script><script src="http://www.visiontv.ca/wp-content/plugins/zm-channel-widget/zm-channel-widget.js?cb=713e2f0fca14c98c96630ea33ee23c9c "></script><script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>

<div class="YAD-23037b07-7c5b-37a3-91a6-5b265629975d"></div>
<script>
                (function (a, b, c, d, e, f) {
                    a[d] || (a[d] =
                        function () {
                            (a[d].q = a[d].q || []).push([arguments, +new Date])
                        });
                    e = b.createElement(c);
                    f = b.getElementsByTagName(c)[0];
                    e.src = 'https://s.yimg.com/uq/syndication/yad.js';
                    e.async = true;
                    f.parentNode.insertBefore(e, f)
                }(window, document, 'script', 'yad'));
                yad('23037b07-7c5b-37a3-91a6-5b265629975d');
            </script>

<script src="https://static.freeskreen.com/publisher/461/freeskreen.min.js"></script>
</body>
</html>
